WOL wieder mal

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • WOL wieder mal

    Hi
    Das Thema WOL wurde zwar schon Xmal behandelt, aber eine wirklich befriedigende Lösung habe -zumindest ich- noch keine gefunden.
    Frage: gibt es eine einfache Möglichkeit das im Prinzip gute WOL Plugin mit einer Funktion zu verknüpfen?
    zB.: NAS aufwecken beim Booten oder bevorstehendem Start einer Aufnahme - da natürlich mit entsprechendem Vorlauf / Bootzeit des NAS.
    Hatte bei meinen früheren Boxen ein kleines "Skript" ? in Verwendung das unter /etc/init.d/networking / eingefügt werden konnte.
    Damit wurde zumindest beim Booten der Box das NAS gestartet und der Bootvorgang wurde dadurch nicht gestoppt. (Netzwerk Freigaben)
    Leider funktioniert das bei den aktuellen Img`s nicht mehr.
    Für das Aufwecken des NAS vor Timeraufnahmen habe ich noch nichts gefunden.
    Der Sinn des Ganzen ist dass ich das im Netzwerk befindliche NAS (OMV Nas) nur für Aufnahmen / Wiedergaben verwende und daher
    eine ständige Bereitschaft nicht sinnvoll erscheint.

    PS : bei "aladin" habe ich einige WOL Plugins gefunden kann aber damit nichts anfangen.

    DANKE für Hinweise zum Thema (falls es jemanden interessiert)

    Gruß
    GBRuPo
  • cricriat wrote:

    Habe das Thema vom "Gäste Forum" nach "Alle Enigma2 Boxen mit openHDF-Support -> Plugins" verschoben.
    Im Gäste Forum ist wohl nicht der richtige Platz dafür, denke ich.

    "Hatte bei meinen früheren Boxen ein kleines "Skript"."
    Hast Du das Skript noch ?
    Falls ja, bitte posten. Eventuell kann man es anpassen.
    Hoffe du kannst damit etwas anfangen

    "Das Wecken selbst ist ganz einfach. Man ergänzt im networking-init-Skript (/etc/init.d/networking) die rot markierte Zeile:




    start)
    echo -n "Configuring network interfaces...
    ifup -a
    ether-wake aa:bb:cc:dd:ee:ff( eigene MAC Adresse !!!!!!!!!!!!)
    echo "done."
    ;;

    2. Da das NAS einige Zeit zum Booten benötigt, muss in der Datei /etc/default/autofs der TIMEOUT so hoch gesetzt werden, dass er die Bootzeit des NAS übertrifft. Bei meiner Synology DS214+ beispielsweise habe ich den TIMEOUT von 5 auf 75 erhöht."

    Hatte das seinerzeit irgendwo aus den Netz
    Ich hoffe, ich begehe da keine Verletzung von Urheberrechten.

    Gruß
    GBRuPo
  • Sicher, dass die Netzwerkkarte im Bastel-NAS das auch kann?
    Nicht alle Netzwerkkarten unterstützen WOL.

    Zum Teil muss man am Zielgerät nach jedem Boot WOL neu aktivieren.

    Beispiel:

    Einstellung meiner Gigablue:

    Supports Wake-on: gs
    Wake-on: d

    p Wake on phy activity
    u Wake on unicast messages
    m Wake on multicast messages
    b Wake on broadcast messages
    a Wake on ARP
    g Wake on MagicPacket(tm)
    s Enable SecureOn(tm) password for MagicPacket(tm)
    d Disable (wake on nothing). This option clears all previous options.

    [email protected]:~# ethtool -s eth0 wol g

    Supports Wake-on: gs
    Wake-on: g
    _________________________________________________________________
    GB ue 4k mit ST3000LM024-2AN1 und Synology + WDMCM über Yamaha RX-V381 an OLED55C8LLA
    AX 4K HD51 mit Synology + WDMCM über Samsung HW-K450 + SWA-8000S an Pioneer PDP-436RXE

    The post was edited 2 times, last by fern-seher ().

  • cricriat wrote:

    Hast Du ether-wake auf der command line mit der richtigen MAC-Adresse
    für das OMV NAS getestet ?

    fern-seher wrote:

    Sicher, dass die Netzwerkkarte im Bastel-NAS das auch kann?
    Nicht alle Netzwerkkarten unterstützen WOL.

    Zum Teil muss man am Zielgerät nach jedem Boot WOL neu aktivieren.

    Beispiel:

    Einstellung meiner Gigablue:

    Supports Wake-on: gs
    Wake-on: d

    p Wake on phy activity
    u Wake on unicast messages
    m Wake on multicast messages
    b Wake on broadcast messages
    a Wake on ARP
    g Wake on MagicPacket(tm)
    s Enable SecureOn(tm) password for MagicPacket(tm)
    d Disable (wake on nothing). This option clears all previous options.

    [email protected]:~# ethtool -s eth0 wol g

    Supports Wake-on: gs
    Wake-on: g
    Cricriat : Ja

    fern-seher : das OMV Nas läßt sich vom Handy, Win PC und von der GB Box aufwecken allerdings nur manuell.
    Mein Frage war, ob man Abhängigkeiten erstellen kann für das Booten oder Timeraufnahmen.

    Hinsichtlich der geposteten Einstellungen deiner GB stehe ich momentan "auf der Leitung" ??

    Danke für euer Interesse an meinem Thema

    GBRuPo
  • Mit "ethtool" kannst Du sehen, was Dein Netzwerk-Interface bezüglich WOL unterstützt und was momentan eingestellt ist.

    Sollte mit Deinem NAS genauso funktionieren.

    Meine Gigablue kann demzufolge WOL, aber es ist nicht aktiviert.

    Mit "ethtool -s eth0 wol g" habe ich es aktiviert.
    _________________________________________________________________
    GB ue 4k mit ST3000LM024-2AN1 und Synology + WDMCM über Yamaha RX-V381 an OLED55C8LLA
    AX 4K HD51 mit Synology + WDMCM über Samsung HW-K450 + SWA-8000S an Pioneer PDP-436RXE
  • Hast Du denn die ether-wake-Zeile in die /etc/init.d/network eingefügt ?
    Und was bekommst Du zu sehen wenn Du auf der command line
    /etc/init.d/network start
    ausführst ?
    Alle Ausgaben und Fehlermeldungen bitte hier posten.

    Solange das Aufwecken des NAS per script nicht funktioniert, ist das Erstellen von Abhängigkeiten
    für das Booten oder Timeraufnahmen eher nachrangig.
  • Damit weckst Du das NAS wenn Du die Box bootest.

    Das hilft Dir aber doch nicht, oder?

    Du müßtest immer, wenn Du Zugriff auf das NAS haben willst, die Box neu booten, wenn das NAS gerade schläft.
    _________________________________________________________________
    GB ue 4k mit ST3000LM024-2AN1 und Synology + WDMCM über Yamaha RX-V381 an OLED55C8LLA
    AX 4K HD51 mit Synology + WDMCM über Samsung HW-K450 + SWA-8000S an Pioneer PDP-436RXE
  • Im Script sollte man den kompletten Pfad angeben:

    [email protected]:~# whereis ether-wake
    ether-wake: /usr/sbin/ether-wake
    _________________________________________________________________
    GB ue 4k mit ST3000LM024-2AN1 und Synology + WDMCM über Yamaha RX-V381 an OLED55C8LLA
    AX 4K HD51 mit Synology + WDMCM über Samsung HW-K450 + SWA-8000S an Pioneer PDP-436RXE
  • Kommt drauf an, wo und wann Du das Script aufrufst.

    Nicht in jedem Fall wird das Profile berücksichtigt.

    Macht sicher Sinn, stdout und errout in eine Datei zu schicken, vielleicht sieht man dann etwas.
    _________________________________________________________________
    GB ue 4k mit ST3000LM024-2AN1 und Synology + WDMCM über Yamaha RX-V381 an OLED55C8LLA
    AX 4K HD51 mit Synology + WDMCM über Samsung HW-K450 + SWA-8000S an Pioneer PDP-436RXE
  • cricriat wrote:

    Hast Du denn die ether-wake-Zeile in die /etc/init.d/network eingefügt ?
    Und was bekommst Du zu sehen wenn Du auf der command line
    /etc/init.d/network start
    ausführst ?
    Alle Ausgaben und Fehlermeldungen bitte hier posten.

    Solange das Aufwecken des NAS per script nicht funktioniert, ist das Erstellen von Abhängigkeiten
    für das Booten oder Timeraufnahmen eher nachrangig.
    Weis nicht ob ich damit zur laufenden Diskussion etwas beitragen kann ?
    das ist der definitive Eintrag in ......"networking"
    Files
  • Mit sysctl wird der Kernel beim Starten des Systems mit verschiedensten Parametern versorgt und konfiguriert.
    Für die Nutzung von ether-wake ist sysctl nicht relevant.

    ether-wake 24:4B:FE:CE:7D:9E steht jetzt so in der /etc/init.d/networking drin und funktioniert nicht ?

    Wenn Du auf der Quad 4K per SSH angemeldet bist und Du
    /etc/init.d/networking start
    auf der command line absetzt, wird das NAS geweckt ?

    Wenn Du
    ether-wake 24:4B:FE:CE:7D:9E
    auf der command line absetzt, wird das NAS geweckt ?

    Setze die folgende Zeile in /etc/rc.local VOR exit 0 ein:
    /usr/sbin/ether-wake 24:4B:FE:CE:7D:9E
    (Entweder mit dem integrierten Editor Deines FTP-Clients oder mit vi oder nano auf der command line
    oder per Notepad++ über den Windows Explorer (Samba))

    Reboote die Quad 4K und schaue ob das NAS aufwacht.
  • cricriat wrote:

    Mit sysctl wird der Kernel beim Starten des Systems mit verschiedensten Parametern versorgt und konfiguriert.
    Für die Nutzung von ether-wake ist sysctl nicht relevant.

    ether-wake 24:4B:FE:CE:7D:9E steht jetzt so in der /etc/init.d/networking drin und funktioniert nicht ?

    Wenn Du auf der Quad 4K per SSH angemeldet bist und Du
    /etc/init.d/networking start
    auf der command line absetzt, wird das NAS geweckt ?

    Wenn Du
    ether-wake 24:4B:FE:CE:7D:9E
    auf der command line absetzt, wird das NAS geweckt ?

    Setze die folgende Zeile in /etc/rc.local VOR exit 0 ein:
    /usr/sbin/ether-wake 24:4B:FE:CE:7D:9E
    (Entweder mit dem integrierten Editor Deines FTP-Clients oder mit vi oder nano auf der command line
    oder per Notepad++ über den Windows Explorer (Samba))

    Reboote die Quad 4K und schaue ob das NAS aufwacht.
    Hi
    1+2 ja wurde geweckt

    mit 3 habe ich irgendwie das Img. gekillt ??
    musste die Box mit rescue mod usw wieder aktivieren.

    aber wir -sorry DU kommst der Sache schon näher

    Gruß aus Wien
    GBRuPo
  • cricriat wrote:

    Ordne bitte Deine Punkte 1,2 und 3 den entsprechenden Abschnitten zu,
    dann gibt es keine Mißverständnisse.

    Bitte den Inhalt Deiner /etc/rc.local hier posten.


    1.)
    ether-wake 24:4B:FE:CE:7D:9E steht jetzt so in der /etc/init.d/networking drin und funktioniert nicht ?
    --wurde so eingefügt UND funktioniert jetzt mit Punkt 1 + 2 jedoch nicht automatisch beim Booten der Box

    2.)
    Wenn Du auf der Quad 4K per SSH angemeldet bist und Du
    /etc/init.d/networking start
    auf der command line absetzt, wird das NAS geweckt ?
    --JA
    3.)
    Wenn Du
    ether-wake 24:4B:FE:CE:7D:9E
    auf der command line absetzt, wird das NAS geweckt ?
    --JA



    (Bitte den Inhalt Deiner /etc/rc.local hier posten.)

    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will "exit 0" on success or any other
    # value on error.
    #
    # By default this script does nothing.

    exit 0

    hoffe ich habe das richtig verstanden und du kannst damit etwas anfangen

    DANKE
  • Shell-Script

    1. #!/bin/sh -e
    2. #
    3. # rc.local
    4. #
    5. # This script is executed at the end of each multiuser runlevel.
    6. # Make sure that the script will "exit 0" on success or any other
    7. # value on error.
    8. #
    9. # By default this script does nothing.
    10. /usr/sbin/ether-wake 24:4B:FE:CE:7D:9E
    11. exit 0
    Display All
    Bitte so übernehmen und nochmals rebooten und sehen ob das NAS aufwacht.

Unsere Partnerboards

^
Flag Counter