Bootzeit pimpen bei 800 UE

    This site uses cookies. By continuing to browse this site, you are agreeing to our use of cookies. More details

      Bootzeit pimpen bei 800 UE

      ich habe mich nochmal meiner GigaBlue HD 800 ue plus angenommen und ihr das neueste Image von Euch spendiert.
      Das Image läuft aber war echt etwas langsam: Bootzeit mehr als 3 Minuten. aber ist gelaufen..

      dann:

      habe einen USB stick mit 8GB genommen und 2 Partitionen in ext4 formatiert (auf einer anderen Box draufgemacht)
      1) auf Partition 2 Swap 512 ...
      2) auf Partition 1 Flashexpander.

      Dann ich wurde dann aufgefordert zum Neustart..aber nix mehr..springt im Display von 50 auf 88 bzw. 89 aber sonnst nix..

      Gruß jarap

      edit:
      also entferne ich den Stick, kann ich tatsächlich wieder booten. Mit dem Stick aber nicht.

      Post was edited 1 time, last by “jarap” ().

      Probiere es mal ohne SWAP. Die GB 800 UE Plus hat eh 512 MB RAM. Das sollte reichen.
      Der Flash mit 128 MB ist allerdings wirklich knapp bemessen. Da kann so ein Flashexpander nicht schaden. Wobei ich persönlich aber dafür Openmultiboot nehmen würde und damit das ganze Image auf den Stick auslagern.
      ____
      Hans



      Achtung: Kein Support über private Nachrichten!

      Edision Optimuss OS1+, Spycat, Zgemma H5.2S+, Zgemma H7C
      TV - Hisense Ultra HD, Astra 19,2° - Unicable LNB


      Hallo Hans,
      habs auch schon ohne swap versucht ..läuft auch net,
      habe jetzt den Stick nochmal nur mit 1 Partition formatiert und mach nur flashexpander drauf..mals sehen ob sich das auswirkt..
      ist Multiboot als Erweiterung verfügbar? ist mir gar nicht aufgefallen..muss ich mal schauen,..

      Post was edited 1 time, last by “jarap” ().

      also nach der der Stick nur 1 Partition hatte und ich den flashexpander installiert habe, funz die Box aber ist jetzt auch nicht irgendwie schneller geworden.
      immer nur das HDF zeichen beim Umschalten. Aber theoretisch läuft sie ja.
      aber Bootzeit ab 3 min.
      Dann aber noch ein Problem, habe IPTV über den HDF Toolbox installiert aber 90 % der IPTV Sender sind nicht enthalten. komisch?
      Naja, die Box ist ja nun wirklich nicht mehr die Neueste.

      Was meinst mit 90 % der IPTV Sender sind nicht enthalten?
      ____
      Hans



      Achtung: Kein Support über private Nachrichten!

      Edision Optimuss OS1+, Spycat, Zgemma H5.2S+, Zgemma H7C
      TV - Hisense Ultra HD, Astra 19,2° - Unicable LNB


      Ich vermute du hast dir das Image zerlegt mit dem Flashexpander.
      Das Problem der Auslagerung ist oft die irreversible Angelegenheit dieser Auslagerung.
      Wenn die Sachen dann nicht mehr vorhanden sind, dann fehlen sie auch im Image.
      Hab einige Zeit mit Flashexpander und auch dem Pendant Tool gearbeitet im sh4 Bereich.
      Aber das macht mehr Probleme als es nutzt.

      Externes swappen ist abhängig von der Geschwindigkeit des Usb-Stick und die sind fast alle extrem lahm bzgl Schreibgeschwindigkeit.
      Swap generell wird aber durchaus benötigt.
      Mips sieht dies aber nicht vor.

      Was bleibt als Empfehlung...
      Multiboot ist eine Option, aber auch da benötigt man einen schnellen USB-Stick.
      Besser ist ein "entschlacktes" System.
      EMC weg und gleich 6-8mb weniger.
      System mit Samba3 statt 4 gebaut gleich 10-15mb weniger.
      Wenn kein Samba benötigt wird, also sofort weg damit.
      Der Start der Box wird es dir auch danken.

      Grüße
      @rantaplan .. so wie du sagst ...ja am besten wäre doch die nicht benötigten Sachen von vorneherein gar nicht in die Installation (natürlich nur bei mir) aufzunehmen.
      Kann ich mir aus den HDF Image nicht ein anderes schlankeres Image bauen. und evt. die CPU höhertakten? Für ausreichende Kühlung habe ich ja schon bereits vorgesorgt.
      Klar kannst dir ein schlankes Image selber bauen.
      Ist ja kein Ding, wenn man denn ein wenig schon mal gebaut hat.

      Mehr als ein Baufehler kann da nicht passieren.
      Aber die mipsel laufen doch artig durch.

      Was müsste eventuell weg...
      github.com/oe-alliance/oe-alli…/openhdf-image.bb#L19-L21
      und
      github.com/oe-alliance/oe-alli…ge/openhdf-enigma2.bb#L32
      und
      github.com/oe-alliance/oe-alli…ge/openhdf-enigma2.bb#L36
      und
      github.com/oe-alliance/oe-alli…e/openhdf-base.bb#L50-L53
      ups das d muss bleiben, aber das sieht man dann sofort;-)

      Je mehr basteln um so besser...
      Ich spar mir ja in meinen Images immer den ganzen gst -"Rotz" und das ist einiges.
      Prinzipiell ist das auch mit Mipsel möglich aber gst ist ein Heiligtum des e2 und darf nicht angerührt werden.
      Rein ffmpeg basierendes Image spart auch noch mal einiges an Speicher.
      sh4 ist es so um die 8mb.

      Leichter ist es aber wirklich wie es oben beschrieben ist.
      Einfach aus dem Tool heraus alles deinstallieren.
      Dann schlank halten.

      Grüße
      also alles ausprobiert, auch multiboot

      letztendlich habe ich 6.3 genommen dann habe ich eine bootzeit unter 3 minuten
      und allerhand deinstalliert = das bringt etwas.

      also Fazit:
      Flashexpander bringt nix
      Swap bringt nix
      Multiboot bringt nix

      aber ich kann IPTV ohne Ruckler schauen
      und oscam läuft auch.

      mehr wollte ich ja gar nicht

      Danke und Gruß
      PluginMover wäre noch einen Versuch wert.
      Auch das empfiehlt sich nur,wenn einem klar ist, das man nicht ständig unnötig aktualisiert.
      Bei einem Neu flash am besten den Stick löschen wo PluginMover drauf ist.
      Dann alles wieder ordentlich einrichten.
      Rückspielen von Einstellungen sind bei Gebrauch solcher Auslagerungen immer etwas problematisch.

      Von der Geschwindigkeit her betrachtet würde ich Picon intern lassen und Plugins auslagern.
      Prinzpiell geht das natürlich auch komplett.
      Sprich e2 stoppen
      Den gesammten Ordner der extension auf USB kopieren
      Dann intern löschen und symlink ertsellen.

      Was mich wunder ist der deutlich langsamere Start unter 6.4
      Das sollte sich nicht verändert haben, denn die Box wird ja "smalflash" gebaut.
      Wenn da irgendwo ein Wurm drin ist, könnte man dies sicher loggen.

      Grüße

      Tante Edit: PluginMover ist auf dem Feed glaub unter PluginSkinMover zu finden;-)

      Post was edited 1 time, last by “rantanplan” ().

      @rantaplan, hab alle Plugins gelöscht bei 6.3 nur der IMDB will nicht gelöscht werden, trotzdem nur 6 MB frei.
      EPG und Picons brauche ich nicht..kann ich die einfach löschen oder gibt es dann ein Bluescreen..

      nachwievor bin ich der Meinung dass so alte Images wo die alte Box unter ne Minute gestartet hat , nachwievor ein Sinn machen würden.
      unter eine Minute Start aus dem Deep?
      Keine Chance!
      Jedenfalls nicht mit e2 und Einbindung vom Netzwerk.
      Ohne Netzwerk macht e2 aber auch nicht so viel Spaß.
      Ohne den Schlangenkram, also Neutrino wird es sicher möglich sein. Aber auch da benötigen die Netzwerk Sachen immer einige Gedenksekunden zum Einbinden.
      Das ist normal und wenn man diese Gedenksekunden zu scharf einstellt, dann macht es nur Probleme.

      EPG Datei wird benötigt und Picon Ordner auch! Wird immer wieder neu angelegt, falls nicht da.

      Mit der Startzeit eines Image unter e2 sollte man sich zufrieden geben.
      Wichtiger ist, das ein Image im Betrieb rund läuft.
      Wenn da ständige Wartezeiten auftreten, dann kann man dort optimieren.
      Der EMC ist hier zum Beispiel schlichtweg ein SuperGau was Resourcen Verschwendung angeht.
      Auch das so "beliebte" Mediaportal geht sehr verschwenderisch mit den Resourcen um.
      Mediaportal ist closed Source.
      EMC hatte daTaDevil glaub als letzter vor3 oder 4 Jahren mal etwas zur CodeVerbesserung beigetragen, seither steht da auch einiges still.

      Führt aber alles zu sehr zum offtopic hier, also bin ich nicht böse wenn man es vom eigentlichen Thema Swapmanager trennt.

      Grüße

    Unsere Partnerboards

    ^
    Flag Counter