bootloader kaputt

    This site uses cookies. By continuing to browse this site, you are agreeing to our use of cookies. More details

      bootloader kaputt

      hi. hdf gemeinde

      wie es scheint ist der bootloader kaputt ... hd51 stb 4k bleibt dauerhaft und am tv kommt kein bild

      ich habe zugriff per ftp-scp
      und putty
      webinterface geht auch nicht

      auf festplatte interne habe ich auch zugriff usb stick weis ich nicht ob erkannt wird

      ach genau bootloader und image gehen nicht per usbstick mit der standby taste sieht so aus als einzigste möglichkeit putty aber ich kriege das mit den befehelen nicht hin

      wie ist der richtige putty befehl zu nem bootloader oder image von festplatte installieren

      oder wie gehe ich in diesem fall vor?

      Danke schonmal!

      das kommt im spoiler bei dem befehl ---- ofgwrite /media/hdd/hd51


      Show Spoiler
      ​Using username "root".
      Filesystem Informations
      Filesystem Size Used Available Use% Mounted on
      /dev/mmcblk0p3 950.3M 240.8M 649.3M 27% /
      devtmpfs 185.8M 4.0K 185.8M 0% /dev
      tmpfs 64.0K 64.0K 0 100% /media
      /dev/mmcblk0p1 3.0M 10.0K 3.0M 0% /boot
      tmpfs 502.0M 4.8M 497.2M 1% /var/volatile
      /dev/sda1 297.9G 206.6G 90.3G 70% /media/hdd
      root@mutant51:~# overwrite
      -bash: overwrite: command not found
      root@mutant51:~# dir
      -bash: dir: command not found
      root@mutant51:~# cd..
      -bash: cd..: command not found
      root@mutant51:~# overwrite
      -bash: overwrite: command not found
      root@mutant51:~# cd dir
      -bash: cd: dir: No such file or directory
      root@mutant51:~# ofgwrite /media/hdd/hd51

      ofgwrite Utility v4.5.5
      Author: Betacentauri
      Based upon: mtd-utils-native-1.5.1 and busybox 1.24.1
      Use at your own risk! Make always a backup before use!
      Don't use it if you use multiple ubi volumes in ubi layer!

      Searching image files in /media/hdd/hd51 resolved to /media/hdd/hd51
      Found kernel file: /media/hdd/hd51/kernel.bin
      Found rootfs file: /media/hdd/hd51/rootfs.tar.bz2
      Setting default parameter: Flashing kernel and rootfs
      Found EXT4 rootfs
      Found mounted /newroot
      Found mountpoint for rootfs file: /media/hdd

      Found /proc/mtd entries:
      Device: Size: Erasesize: Name: Image:
      Using kernel mtd device:
      Using rootfs mtd device:
      Read /proc/cmdline
      Current rootfs is: /dev/mmcblk0p3
      Current kernel is: /dev/mmcblk0p2
      Current root sub dir is: linuxrootfs1

      Execute: fdisk -l
      Found valid GPT with protective MBR; using GPT

      No matching partition names are found. Use current kernel and rootfs devices
      Using current multiboot partition 1
      Using /dev/mmcblk0p2 as kernel device
      Using /dev/mmcblk0p3 as rootfs device

      /dev/fb0: No such file or directory
      framebuffer not available.
      killall: CCcam: no process killed

      Usage:
      kill [options] <pid> [...]

      Options:
      <pid> [...] send signal to every <pid> listed
      -<signal>, -s, --signal <signal>
      specify the <signal> to be sent
      -l, --list=[<signal>] list all signal names, or convert one to a name
      -L, --table list all signal names in a nice table

      -h, --help display this help and exit
      -V, --version output version information and exit

      For more details see kill(1).

      Usage:
      kill [options] <pid> [...]

      Options:
      <pid> [...] send signal to every <pid> listed
      -<signal>, -s, --signal <signal>
      specify the <signal> to be sent
      -l, --list=[<signal>] list all signal names, or convert one to a name
      -L, --table list all signal names in a nice table

      -h, --help display this help and exit
      -V, --version output version information and exit

      For more details see kill(1).
      killall: kodi.bin: no process killed
      killall: hddtemp: no process killed
      killall: transmission-daemon: no process killed
      killall: openvpn: no process killed
      sh: /etc/init.d/sabnzbd: No such file or directory
      Stopping automount: done.
      Syncing filesystem
      daemonize
      successful
      root@mutant51:~# start umount_rootfs
      cp: can't stat '/lib/libcrypt*': No such file or directory
      Switching to user mode 2
      Checking E2 is running...
      Execute: ps
      E2 is stopped
      /dev/fb0: No such file or directory
      framebuffer not available.
      /dev/dvb/adapter0/video0: No such file or directory
      Error: Found no background image, or image is unusable
      Move mountpoint of image files
      Moving /oldroot/media/hdd to /media/hdd
      umounting: /media/autofs
      umounting: /proc/fs/nfsd
      umounting: /sys/fs/fuse/connections
      umounting: /boot
      umounting: /media
      umounting: /sys/kernel/debug
      failed to to open old config /etc/default/autofs
      /bin/automount: program is already running.
      Execute: fuser -k -m /oldroot/

      Post was edited 2 times, last by “maxim000” ().

      Mit USB Stick flashen. Wenn die Box startet (FTP und SSH geht ja) dann ist der Bootloader nicht defekt.
      Meine Bastelboxen: Mut@nt HD51 | GB Quad 4K | Mut@nt HD60 | OSMIO4K | HIS 4k Combo+

      ... Keinen Support per PN ... bitte stellt eure Fragen ins Forum!...

      ~ Benutzung OpenHDF Image ~ Benutzung der HDF-Toolbox ~ FAQ und Linksammlung ~ Build und Foren Server Spendenaktion ~
      Gib mal im Telnet ein

      Source Code

      1. opkg update
      2. opkg upgrade


      Wenn das durchgelaufen ist, boote mal neu und teste nochmals.
      ____
      Hans



      Achtung: Kein Support über private Nachrichten!

      Edision Optimuss OS1+, Spycat, Zgemma H5.2S+, Zgemma H7C
      TV - Hisense Ultra HD, Astra 19,2° - Unicable LNB


      im receiver eventuelle festplatten abziehn

      usb anstecken mit ordner hd51 drauf
      strom anstecken und nun 5 sek taste vorn links dauerhaft drücken, nun muss der anfangen zu flashen
      1x Triplex alter Sattuner + dvb-C/T --- 2x Triplex neuer Sattuner + Dvb-C/T2 --- LX 2 1 Sat+ Dvb-C/T2 --- 4x Dbox1 --- 2x Pace --- 1x GM990 reloaded 1x Pingulux (alte)
      Wie alt ist das Image (Erstinstallation) ?
      Wurde seitdem nur aktualisiert oder auch mal neu installiert (geflasht)?
      Es hat sich ja in der Speicherverwaltung einiges verändert !

      Zitiere mich mal selbst:
      "Wichtiger Bootloader Update für die HD51 V107r27von 30.05.2019
      Bitte diesen Bootloader dringend Installieren !!

      dieser Bootloader wird benötigt für Images ab Mai 2019

      und jetzt neu r27 (Fix Recovery)

      * Fix div Probleme (Images ab Mai 2019)

      INFO

      auch ältere Image laufen anschließend problemlos !

      Box ausgeschaltet
      HD51 Verzeichnis auf einen USB-Stick kopiert
      USB-Stick in den Front-USB gesteckt, lange auf Powertaste gedrückt.
      Im Display steht dann "bolt", nach 2-4 Sekunden steht dann "complete" und die Box startet neu.
      Im Image dann per > Blau > Grün kontrolliert ob die neue Bootloader-Version drin steht."
      Files
      ______
      Gruß
      Skip
      :friend:

      New

      Hänge mich hier mal an die Antwort von Skipper an.

      Hatte ein gut funktionierendes System auf Basis 6.2 (glaube 166).
      Ab und zu gab es Probleme, die sich aber (wie immer) durch Stecker ziehen lösen ließen.
      Man musste nur Geduld haben.
      (Nebenbei bemerkt, der Trick mit 10 sec. beim Anschalten funktioniert bei mir nicht, ich lande immer in Start_Up3, obwohl 1 und 2 belegt sind)

      Irgendwann stellte ich fest, dass Online-Updates nicht mehr gingen.
      Die Ursachenforschung führte zum Bootloader.
      Ab da ging es los.

      Dass nach dem Bootloader-Update alles weg ist, hatte ich leider zu spät gelesen, aber was soll`s.

      Sicherungen in Form der Senderliste und Oscam waren ja da.

      Allerdings lies sich das Webinterface von Oscam nicht mehr aufrufen!
      Normales Web-IF, FTP, Netzwerkstatus, alles war vorhanden und funktionierte, nur das Oscam Web-IF nicht.
      Warum?

      Nach einem halben Nachmittag intensiver Google-Suche brachte die Löschung einiger Dateien die Lösung (welche genau weiß ich nicht).

      Eigentlich gilt der Grundsatz "Never change a running System", aber manchesmal ist man einfach neugierig.
      Jetzt gilt es, alles neu aufzubauen.

    Unsere Partnerboards

    MOSC
    Flag Counter