SF228 E2 HD LCD TWIN - Zeit bzw. Netzwerk einstellen

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • SF228 E2 HD LCD TWIN - Zeit bzw. Netzwerk einstellen

      Hallo!

      Nachdem ich einen SF228 erfolgreich auf 6.4 upgedatet habe und der ORF wieder läuft habe ich das Gerät retourniert - und es gibt das nächste Problem :( Keine aktuelle Zeit. :(

      Bei mir habe ich ihn einfach über LAN angesteckt, hat gleich geklappt und er hat sich auch die aktuelle Zeit geholt.
      Am Heimatort des Receivers gibts leider kein LAN. Darum wurde zuerst über den Transponder versucht die Zeit zu erhalten... nicht geklappt... danach WLAN einzurichten... auch nicht geklappt.

      Habe nun folgende Fragen:
      1) Gibts irgendeine Möglichkeit Uhrzeit/Datum manuell einzustellen? Laut dem Besitzer hat er nix gefunden - würde das Problem aber nur halb lösen, da das Gerät immer wieder tagelang nicht genutzt wird und da mit einem Kippschalter vom Storm getrennt ist - wäre aber zumindest etwas ;)

      2) Gibts über die eine Einstellung hinaus noch eine Möglichkeit dem Receiver zu sagen, dass er die Zeit über den Transponder beziehen soll? Nur diese Einstellung scheint nix zu bewirken (auch wenn man 20min+ wartet)

      3) Kann da etwas bei den WLAN Einstellungen übersehen worden sein? Die angegebenen Werte (siehe Screenshot) sind korrekt, auch das PW konnte ich verifizieren (Foto der Router unterseite hab ich auch bekommen ;) )

      Das Problem ist, dass das Gerät über 2 Autostunden entfernt ist, ich mich selber in Bezug auf Recevier als DAU bezeichnen würde und der Besitzer noch ein paar Stufen drunter ist ;)

      Habt ihr eine Idee?
      Helfen die Screenshots oder werden andere Infos benötigt?


      Danke auch euch :)
      Images
      • Menü.jpg

        88.92 kB, 1,200×1,600, viewed 80 times
      • Zeit.jpg

        76.74 kB, 1,200×1,600, viewed 74 times
      • WLAN-Konfig1.jpg

        96.79 kB, 1,200×1,600, viewed 70 times
      • WLAN-Konfig1.1.PNG

        597.46 kB, 1,072×607, viewed 80 times
    • Uhrzeit kannst auch über Telnet eingeben.
      sven-kuegler.de/ubuntu/systemzeit-und-datum-manuell-setzen

      Eigentlich sollte auch funzen die Zeit über den Transponder zu beziehen. Möglicherweise funzt das aber nur, wenn die Systemzeit nicht allzu weit entfernt ist.

      Versuche mal bei WLAN bei Verschlüsselung "WPA oder WPA2" einzustellen.
      ____
      Hans



      Achtung: Kein Support über private Nachrichten!

      Edision Optimuss OS1+, Spycat, Zgemma H9.Twin
      TV - Hisense Ultra HD, Astra 19,2° - Unicable LNB
    • Einfachste Methode zum manuellen Setzen der Uhrzeit:

      Per SSH an Deiner Box als root anmelden.


      date 03272043 (Beispiel) # date MMDDhhmm

      MM steht für Monat
      DD steht für Tag
      hh steht für Stunde
      mm steht für Minute

      hwclock steht auf den enigma2 Boxen nicht zur Verfügung.
      Auch Installation von "opkg install util-linux-hwclock" ist zwecklos,
      da hwclock kein Interface zur RTC findet.

      Source Code

      1. ./hwclock.util-linux -v
      2. hwclock.util-linux from util-linux 2.37.2
      3. System Time: 1651330470.935218
      4. Trying to open: /dev/rtc0
      5. Trying to open: /dev/rtc
      6. Trying to open: /dev/misc/rtc
      7. No usable clock interface found.
      8. hwclock.util-linux: Cannot access the Hardware Clock via any known method.

      Auch
      ./hwclock.util-linux -v -f /proc/stb/fp/rtc
      schlägt fehl:

      Source Code

      1. ./hwclock.util-linux -v -f /proc/stb/fp/rtc
      2. hwclock.util-linux from util-linux 2.37.2
      3. System Time: 1651331122.209718
      4. Using the rtc interface to the clock.
      5. Assuming hardware clock is kept in UTC time.
      6. Waiting for clock tick...
      7. ioctl(3, RTC_UIE_ON, 0): Inappropriate ioctl for device
      8. Waiting in loop for time from /proc/stb/fp/rtc to change
      9. hwclock.util-linux: ioctl(RTC_RD_TIME) to /proc/stb/fp/rtc to read the time failed: Inappropriate ioctl for device
      10. ...synchronization failed
    • Danke Mal für die Tipps!
      D.h. Zeit geht wirklich nicht übers Interface, bezüglich Transponder gibt's da scheinbar auch keinen Geheimtrick *gg*

      Somit nochmal das mim WLAN anschauen, danke für die Idee mit der Verschlüsselung, werden das probieren.

      Ansonsten muss ich echt Mal vor Ort vorbeischauen, das mit Laptop anschließen wird sonst wohl zu viel ;) Aber schade, dass er dann auf Dauerstrom bleiben muss :(
    • So, Problem gelöst - wie üblich ist es vor dem Bildschirm gesessen ;)

      Ich habe genauso wie der Nutzer eine Fritzbox - sogar das gleiche Modell.
      Die hat sich der Receiver vom flashen gemerkt gehabt.
      Die Fritzbox hat nach der Modellnummer zwei zufällige Buchstaben. Der Nutzer hatte das falsche (bei ihm Vorort natürlich auch nicht verfügbare) Netzwerk zu konfigurieren versucht.

      Mit dem richtigen Netzwerk geht es auch...

      Sorry für das Zeitstehlen :(
      War mir selber nicht bewusst und wenn man nicht davor sitzt kommt man nur schwer auf sowas drauf.

    Unsere Partnerboards

    ^
    Flag Counter