Falsche Zeit und falsches Datum

    This site uses cookies. By continuing to browse this site, you are agreeing to our use of cookies. More details

      Googgi wrote:

      Europe > Berlin > Transponder wäre aktuell richtig.
      Ändere das mal.


      kaltvront wrote:

      So hatte ich es ja zuerst; wobei man das ja nicht genau so einstellen kann, wie Du schreibst.


      doch - genau so stellt man das ein.

      Siehe auch Screenshot von @zeini

      Alle Fragen bitte im Forum stellen!
      Anfragen via PN oder Mail werden gelöscht.

      >>> Liste aller mit openhdf-Image supporteten Boxenmodelle <<<

      Moin zusammen :) .
      Also irgendwas is hier komplett durcheinander. Ich hatte mich ja schon über Googgi`s "Europe -> Berlin -> ..." gewundert, jetzt noch zeini`s Screenshot. Bei mir sieht das so aus wie im Anhang, wie gesagt HDF 6.4.

      So, nun zu cricriat. Habe eben nochmal die Konsole bemüht. Wie Du siehst, ist der erste Eintrag 10:16:56. Da habe ich die Zeiteinstellung noch so wie im Screenshot. Dann habe ich sie auf "Amsterdam, Berlin, ..." umgestellt und nochmal "date; ntpdate 192.53.103.108; date" eingegeben, dann kommen auch 2 Minusstunden raus (08:18:41).

      Source Code

      1. [email protected]:~# date; ntpdate 192.53.103.108; date
      2. Sat Apr 18 10:16:50 CAT 2020
      3. 18 Apr 10:16:56 ntpdate[30242]: adjust time server 192.53.103.108 offset 0.02713 1 sec
      4. Sat Apr 18 10:16:56 CAT 2020
      5. [email protected]:~# date; ntpdate 192.53.103.108; date
      6. Sat Apr 18 08:18:41 UTC 2020
      7. 18 Apr 08:18:47 ntpdate[30419]: adjust time server 192.53.103.108 offset -0.011251 sec
      8. Sat Apr 18 08:18:48 UTC 2020
      9. [email protected]:~#


      Keine Ahnung, wo da das Problem liegt. Auf den anderen Receivern habe ich noch gar nicht geguckt, ob die dieses Prob auch haben. Die haben aber andere Probleme, da muß ich mal noch hier im Forum an anderer Stelle nachfragen.

      Viele Grüße,
      Andi
      Images
      • ScreenGrabber.jpg

        72.58 kB, 1,280×720, viewed 18 times
      Vielleicht mal etwas allgemein zur Uhrzeit in Linux Systemen. Dass der Rechner UTC anzeigt ist eigentlich korrekt. Linux stellt die Systemuhr immer auf UTC, auch bei PCs im Gegensatz zu Windows. Und Linux hat dann eine Konfiguration für die Zeitzone und berechnet dann aus der UTC Systemzeit und der in der Konfiguration eingestellten Zeitzone die tatsächliche Zeit. Deshalb haben Leute die Windows und Linux im Dualboot betreiben auch immer Probleme mit der Systemzeit. Win stellt die Zeit (auch die der CMos Uhr) auf aktuelle Zeitzone und Linux stellt auf UTC....
      Ja. Wobei man sowohl Windows leicht beibringen kann, von UTC im BIOS auszugehen, wie auch Linux von lokaler Zeit auszugehen. Spielt aber heutzutage meines Erachtens nicht mehr so die Rolle, da sich typischerweise beide Betriebssysteme während des Bootens die Zeit synchronisieren mit einer externen Quelle. Dann stimmt die Zeit auch, da sich die Systeme ja die Zeitzone merken. Allerdings wird dann die HW-Uhr immer hin und her geschaltet im Multiboot. (Klar, sehr seltene Programme, die direkt auf die HW-Uhr zugreifen müssen, können durcheinander kommen, wenn sie nicht entsprechend programmiert sind, und von der üblichen Konvention ausgehen.)

      msrx111 wrote:

      Dass der Rechner UTC anzeigt ist eigentlich korrekt.


      Das allerdings sehe ich nicht so. Meinst du vielleicht auch nicht so. Der Rechner soll die Zeit, die der Programmierer für richtig hält/die für die Situation passt, anzeigen. Und das tut er auch, wenn alles richtig konfigurieret ist, unabhängig von der Konvention der CMOS Uhr. Traditionell in Unix wie in Windows wie auf MacOS sind das systemunabhängige Funktionen, wie localtime() und gmtime() (das man heute vermutlich anders nennen würde). Die Grundfunktion time() ist (natürlich) Zeitzonen-unabhängig. Mit was die Betriebssysteme jetzt intern rechnen ist dafür aber nicht wichtig. (Sowohl Windows als auch Unix als auch Windows rechnen intern mit zeitzonen-unabhängiger Zeit.)

      Manchmal kommt übrigens noch eine weitere Stufe hinzu. In beispielsweise "Terminal-Server-Umgebungen" arbeiten Benutzer, Anzeige erfolgt auf dem Endgerät der Benutzer, der Server steht in einem Rechenzentrum (RZ). User loggen sich im Terminal-Server ein und sehen eine normale Windows-Oberfläche. Der Terminalserver hat seine Zeitzone, normalerweise die des RZs in dem er steht. Gleichzeitig loggen sich User ein aus verschiedenen Zeitzonen. Die wünschen sich alle ihre Uhr in der Ecke in der lokalen Zeit (und nicht in der des RZ). Auch das funktioniert.
      Ja, Harare und Pretoria haben die gleiche Zeit wie bei uns in Deutschland.
      Ist jetzt nicht unbedingt falsch, wenn du das eingestellt hast (aber ein Schönheitsfehler). Ich denke, dass es da auch eine deutsche Stadt gibt, die du einstellen kannst.
      ____
      Hans



      Achtung: Kein Support über private Nachrichten!

      Edision Optimuss OS1+, Spycat, Zgemma H5.2S+, Zgemma H7C
      TV - Hisense Ultra HD, Astra 19,2° - Unicable LNB


      zeini wrote:

      Ja, Harare und Pretoria haben die gleiche Zeit wie bei uns in Deutschland.
      Ist jetzt nicht unbedingt falsch, wenn du das eingestellt hast (aber ein Schönheitsfehler). Ich denke, dass es da auch eine deutsche Stadt gibt, die du einstellen kannst.


      Ja, aber wie soll ich denn eine andere deutsche Stadt einstellen, wenn ich gar nicht so ein Menü habe? :)
      Auf dem [email protected] mit HDF 6.4 #123 ist übrigens auch noch das Menü für Zeiteinstellung wie auf dem OS Mega, der Optimuss mit HDF 6.4 #13x (weiß grad net genau) hat das wie auf euren Screenshots. Der [email protected] zeigt aber die korrekte Uhrzeit.
      Schön wäre eigentlich, wenn man die Zeiteinstellung im Menü auf manuell bzw. AUS stellen könnte und dann über Konsole wie bei Linux die Uhrzeit eingibt.


      Übrigens, laut Google kann man mit dem Bus von Harare nach Pretoria fahren, kostet zw. 20 u. 30€. Für >1000 km!!!! =O =O :thumbsup:

      Andi
      Mit den neusten Updates hast du in den Zeiteinstellungen eine Auswahl wie in diviersen Screenshots beschrieben.
      Ist das nicht der Fall gab es beim Updaten ein Problem und ein Neuflash ist notwendig, dann geht wieder alles.
      ______
      Gruß
      Skip
      :friend:

      Kein Support via PN. Fragen gehören ins Forum

      cricriat wrote:

      Mache bitte mal screenshots von:
      Menü -> Informationen -> Über

      und von den Zeit-Menüs, die Du auf der OS Mega hast.


      Zeitmenü hatte ich schon weiter oben drin, Info hängt unten dran.

      @CV-Skipper:
      Ja, hab mir auch gerade mal die letzte 6.5er gesaugt. Läuft das auf eine komplette Neuinstallation hinaus oder kann ich die Einstellungen übernehmen? Könnte ja sein, daß der Fehler dann mitgenommen wird, oder?
      Und gleich noch ne Frage: wenn ich meine Receiver update, kommt immer der Hinweis, daß das Image veraltet ist. Für Mutant und Optimuss gibt es aber keine neueren Images. Wieso dann die Meldung?
      Images
      • ScreenGrabber02.jpg

        167.55 kB, 1,920×1,080, viewed 14 times
      Gibt ja auch für deine Edision eine neuere Version >> v64.hdfreaks.cc/osmega/openhdf…mega-133-20200404_usb.zip
      Klar kommt da, das das Image zu alt ist - du hast #124 drauf, wir sind mittlerweile bei #133 !
      Und auch bei den anderen Receivern ist der Kernel nicht aktuell, aber es wird für diese alten Receiver nichts aktuelles mehr gebaut, auch deshalb, weil die Boxen damit teilweise nicht zurecht kommen und sehr langsam würden.
      Und ja, wenn du alte Einstellungen übernimmst, wird u.U. auch der Fehler wieder mit übernommen. Aber das Auszuprobieren dauert ja gerade mal 10 Minuten, wenn es nicht klappt, musst du in den sauren Apfel beißen und neu einrichten.
      Settings vorher sichern !
      ______
      Gruß
      Skip
      :friend:

      Kein Support via PN. Fragen gehören ins Forum

    Unsere Partnerboards

    ^
    Flag Counter