new MultiBoot - Problem

This site uses cookies. By continuing to browse this site, you are agreeing to our use of cookies. More details

    new MultiBoot - Problem

    Ich habe in die erste Partition das Image OpenHDF 6.4.73 (2019-05-13) online geflasht und dann neu gestartet.

    Danach habe ich das OpenATV Image vom 13.05.2019 in die Partition 4 geflasht.

    Wenn ich nun - egal in welchem Image - im MultiBoot Menü das jeweils andere Image auswähle und neu starte, gibt es keine Änderung. Es wird immer wieder das gleiche Image gestartet.

    Wenn ich allerdings in der Datei

    /boot/STARTUP

    den Eintrag der Partition ändere, dann wird das jeweils andere Image gestartet.

    Geändert von
    boot emmcflash0.kernel1 'brcm_cma=440M@328M brcm_cma=192M@768M root=/dev/mmcblk0p3 rw rootwait hd51_4.boxmode=1'
    in
    boot emmcflash0.kernel4 'brcm_cma=440M@328M brcm_cma=192M@768M root=/dev/mmcblk0p9 rw rootwait hd51_4.boxmode=1'



    Woran kann das liegen?



    Lösung:

    Mit dem neuen MultiBoot muss das aktuelle Image einmalig frisch von USB geflasht werden!

    _________________________________________________________________
    AX 4K HD51 mit ST3000LM024-2AN1 und WD MyCloud Mirror G2 über Yamaha RX-V381 an OLED55C8LLA
    ET10000 mit WDC WD30EZRX-00M und WD MyCloud Mirror G2 über Samsung HW-K450 + SWA-8000S an Pioneer PDP-436RXE mit OpenMultiBoot

    Post was edited 1 time, last by “fern-seher” ().

    Werde ich mal probieren …

    Bisher war es ja so, dass im Verzeichnis

    /boot

    die jeweiligen EInträge standen und beim Auswählen der Inhalt der jeweiligen Datei (die man auch umbenennen konnte) in die Datei STARTUP kopiert wurde.
    Das war dann der aktive Eintrag.

    Genau dieses Kopieren scheint nicht zu funktionieren, aber warum?
    Wenn ich es per Hand mache, geht es doch.
    _________________________________________________________________
    AX 4K HD51 mit ST3000LM024-2AN1 und WD MyCloud Mirror G2 über Yamaha RX-V381 an OLED55C8LLA
    ET10000 mit WDC WD30EZRX-00M und WD MyCloud Mirror G2 über Samsung HW-K450 + SWA-8000S an Pioneer PDP-436RXE mit OpenMultiBoot
    Könnte mir jemand bitte mal die Ausgabe von

    ls -l /boot

    schicken?

    Wie heißen die Einträge per default?
    _________________________________________________________________
    AX 4K HD51 mit ST3000LM024-2AN1 und WD MyCloud Mirror G2 über Yamaha RX-V381 an OLED55C8LLA
    ET10000 mit WDC WD30EZRX-00M und WD MyCloud Mirror G2 über Samsung HW-K450 + SWA-8000S an Pioneer PDP-436RXE mit OpenMultiBoot
    Hast du auch nur "neue" Images mit dem neuen Multiboot? Die alten laufen dann nicht mehr. Und bitte nicht in mehreren Beitrage schreiben und fragen.
    ____
    Hans



    Achtung: Kein Support über private Nachrichten!

    Edision Optimuss OS1+, Spycat, Zgemma H5.2S+, Zgemma H7C
    TV - Hisense Ultra HD, Astra 19,2° - Unicable LNB


    new MultiBoot - Problem

    Ja, 2 neue Images, wie schon gesagt.

    Im anderen Threat wollte ich nur mal fragen, ob es prinzipiell funktioniert, da das Setup sehr ähnlich ist.

    Gesendet von meinem EML-L09 mit Tapatalk
    _________________________________________________________________
    AX 4K HD51 mit ST3000LM024-2AN1 und WD MyCloud Mirror G2 über Yamaha RX-V381 an OLED55C8LLA
    ET10000 mit WDC WD30EZRX-00M und WD MyCloud Mirror G2 über Samsung HW-K450 + SWA-8000S an Pioneer PDP-436RXE mit OpenMultiBoot
    root@mutant51:~# ls -l /boot
    -rwxr-xr-x 1 root root 163 May 14 09:58 STARTUP
    -rwxr-xr-x 1 root root 163 May 5 10:57 STARTUP_1
    -rwxr-xr-x 1 root root 164 May 5 10:57 STARTUP_2
    -rwxr-xr-x 1 root root 164 May 5 10:57 STARTUP_3
    -rwxr-xr-x 1 root root 164 May 5 10:57 STARTUP_4
    Und die Inhalte dazu:

    Source Code

    1. boot emmcflash0.linuxkernel 'brcm_cma=440M@328M brcm_cma=192M@768M root=/dev/mmcblk0p3 rootsubdir=linuxrootfs1 kernel=/dev/mmcblk0p2 rw rootwait hd51_4.boxmode=1'

    Source Code

    1. boot emmcflash0.linuxkernel2 'brcm_cma=440M@328M brcm_cma=192M@768M root=/dev/mmcblk0p7 rootsubdir=linuxrootfs2 kernel=/dev/mmcblk0p4 rw rootwait hd51_4.boxmode=1'

    Source Code

    1. boot emmcflash0.linuxkernel3 'brcm_cma=440M@328M brcm_cma=192M@768M root=/dev/mmcblk0p7 rootsubdir=linuxrootfs3 kernel=/dev/mmcblk0p5 rw rootwait hd51_4.boxmode=1'

    Source Code

    1. boot emmcflash0.linuxkernel4 'brcm_cma=440M@328M brcm_cma=192M@768M root=/dev/mmcblk0p7 rootsubdir=linuxrootfs4 kernel=/dev/mmcblk0p6 rw rootwait hd51_4.boxmode=1'

    Meine Bastelboxen: Mut@nt HD51 | GB Quad 4K | Mut@nt HD60 | OSMIO4K | HIS 4k Combo+

    ... Keinen Support per PN ... bitte stellt eure Fragen ins Forum!...

    ~ Benutzung OpenHDF Image ~ Benutzung der HDF-Toolbox ~ FAQ und Linksammlung ~ Build und Foren Server Spendenaktion ~
    Vielen Dank!

    Sieht bei mir (noch) anders aus.

    Deins:
    boot emmcflash0.linuxkernel 'brcm_cma=440M@328M brcm_cma=192M@768M root=/dev/mmcblk0p3 rootsubdir=linuxrootfs1 kernel=/dev/mmcblk0p2 rw rootwait hd51_4.boxmode=1'

    meins:
    boot emmcflash0.kernel1 'brcm_cma=440M@328M brcm_cma=192M@768M root=/dev/mmcblk0p3 rw rootwait hd51_4.boxmode=1'


    Hast Du die Box online oder von USB geflasht?

    Wenn ich in das aktuelle ZIP Image reinschaue, dann ist im Image das /boot Verzeichnis leer, kommt also nicht direkt aus dem Image sondern wird irgendwann erzeugt bzw. beibehalten.
    _________________________________________________________________
    AX 4K HD51 mit ST3000LM024-2AN1 und WD MyCloud Mirror G2 über Yamaha RX-V381 an OLED55C8LLA
    ET10000 mit WDC WD30EZRX-00M und WD MyCloud Mirror G2 über Samsung HW-K450 + SWA-8000S an Pioneer PDP-436RXE mit OpenMultiBoot
    Ich habe das aktuelle HDF Image per USB geflasht. Ist ja nur einmal notwendig.
    Dauert aber gut 10 Minuten oder länger und danach passte alles.
    Meine Bastelboxen: Mut@nt HD51 | GB Quad 4K | Mut@nt HD60 | OSMIO4K | HIS 4k Combo+

    ... Keinen Support per PN ... bitte stellt eure Fragen ins Forum!...

    ~ Benutzung OpenHDF Image ~ Benutzung der HDF-Toolbox ~ FAQ und Linksammlung ~ Build und Foren Server Spendenaktion ~
    Ich habe jetzt mal den Inhalt von STARTUP_4 aktualisiert (die Einträge von Dir) und dann dahin gewechselt.

    Die BOX hat jetzt die STARTUP aktualisiert (mit dem Inhalt von STARTUP_4).

    Gebootet hat sie dann aber gar nicht. Per Notprozedur (Power Button gedrückt halten) habe ich dann wieder Startup 1 gebootet und jetzt crasht Enigma beim Aufruf des Multiboot Menüs.
    _________________________________________________________________
    AX 4K HD51 mit ST3000LM024-2AN1 und WD MyCloud Mirror G2 über Yamaha RX-V381 an OLED55C8LLA
    ET10000 mit WDC WD30EZRX-00M und WD MyCloud Mirror G2 über Samsung HW-K450 + SWA-8000S an Pioneer PDP-436RXE mit OpenMultiBoot
    Hast du auch das erste "neue" mage auf die Box mittels USB-Flash direkt - also ohne onlineflash installiert?
    ____
    Hans



    Achtung: Kein Support über private Nachrichten!

    Edision Optimuss OS1+, Spycat, Zgemma H5.2S+, Zgemma H7C
    TV - Hisense Ultra HD, Astra 19,2° - Unicable LNB


    Eben nicht … hatte ich bisher auch nirgendwo gelesen.
    _________________________________________________________________
    AX 4K HD51 mit ST3000LM024-2AN1 und WD MyCloud Mirror G2 über Yamaha RX-V381 an OLED55C8LLA
    ET10000 mit WDC WD30EZRX-00M und WD MyCloud Mirror G2 über Samsung HW-K450 + SWA-8000S an Pioneer PDP-436RXE mit OpenMultiBoot
    Stimmt, ich habe das mal im Thread von Koivo dazu geschrieben
    HD51/AX51+ZgemmaH7 Änderungen im Multiboot

    Dann sichere mal deine Einstellungen und mache das. Danach sollte alles wieder so funzen wie gewohnt.
    ____
    Hans



    Achtung: Kein Support über private Nachrichten!

    Edision Optimuss OS1+, Spycat, Zgemma H5.2S+, Zgemma H7C
    TV - Hisense Ultra HD, Astra 19,2° - Unicable LNB


    Die Box flasht gerade ...
    _________________________________________________________________
    AX 4K HD51 mit ST3000LM024-2AN1 und WD MyCloud Mirror G2 über Yamaha RX-V381 an OLED55C8LLA
    ET10000 mit WDC WD30EZRX-00M und WD MyCloud Mirror G2 über Samsung HW-K450 + SWA-8000S an Pioneer PDP-436RXE mit OpenMultiBoot
    So, läuft wieder …

    Mein aktueller STARTUP EIntrag sieht jetzt auch so aus:

    boot emmcflash0.linuxkernel 'brcm_cma=440M@328M brcm_cma=192M@768M root=/dev/mmcblk0p3 rootsubdir=linuxrootfs1 kernel=/dev/mmcblk0p2 rw rootwait hd51_4.boxmode=1'


    Der interne Speicher ist jetzt anders aufgeteilt:

    vorher
    root@ax51:~# lsblk
    NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
    sda 8:0 0 2.7T 0 disk
    `-sda1 8:1 0 2.7T 0 part /media/hdd
    mmcblk0 179:0 0 3.7G 0 disk
    |-mmcblk0p1 179:1 0 3M 0 part /boot
    |-mmcblk0p2 179:2 0 8M 0 part
    |-mmcblk0p3 179:3 0 800M 0 part /
    |-mmcblk0p4 179:4 0 8M 0 part
    |-mmcblk0p5 179:5 0 800M 0 part
    |-mmcblk0p6 179:6 0 8M 0 part
    |-mmcblk0p7 179:7 0 800M 0 part
    |-mmcblk0p8 179:8 0 8M 0 part
    |-mmcblk0p9 179:9 0 800M 0 part
    `-mmcblk0p10 179:10 0 491M 0 part [SWAP]
    mmcblk0boot0 179:16 0 2M 1 disk
    mmcblk0boot1 179:32 0 2M 1 disk
    mmcblk0rpmb 179:48 0 128K 0 disk



    jetzt:
    root@ax51:~# lsblk
    NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
    sda 8:0 0 2.7T 0 disk
    `-sda1 8:1 0 2.7T 0 part /media/hdd
    mmcblk0 179:0 0 3.7G 0 disk
    |-mmcblk0p1 179:1 0 3M 0 part /boot
    |-mmcblk0p2 179:2 0 8M 0 part
    |-mmcblk0p3 179:3 0 1G 0 part /
    |-mmcblk0p4 179:4 0 8M 0 part
    |-mmcblk0p5 179:5 0 8M 0 part
    |-mmcblk0p6 179:6 0 8M 0 part
    `-mmcblk0p7 179:7 0 2.6G 0 part
    mmcblk0boot0 179:16 0 2M 1 disk
    mmcblk0boot1 179:32 0 2M 1 disk
    mmcblk0rpmb 179:48 0 128K 0 disk
    _________________________________________________________________
    AX 4K HD51 mit ST3000LM024-2AN1 und WD MyCloud Mirror G2 über Yamaha RX-V381 an OLED55C8LLA
    ET10000 mit WDC WD30EZRX-00M und WD MyCloud Mirror G2 über Samsung HW-K450 + SWA-8000S an Pioneer PDP-436RXE mit OpenMultiBoot
    @zeini Vielleicht solltest Du das mit dem USB Flash GROSS und FETT schreiben …

    ;)
    _________________________________________________________________
    AX 4K HD51 mit ST3000LM024-2AN1 und WD MyCloud Mirror G2 über Yamaha RX-V381 an OLED55C8LLA
    ET10000 mit WDC WD30EZRX-00M und WD MyCloud Mirror G2 über Samsung HW-K450 + SWA-8000S an Pioneer PDP-436RXE mit OpenMultiBoot
    Da habe ich doch etwas gelesen … war das hier?

    github.com/openhdf/enigma2/com…f4e49f98f827c90eb02e530e7

    Wie funktioniert das?
    _________________________________________________________________
    AX 4K HD51 mit ST3000LM024-2AN1 und WD MyCloud Mirror G2 über Yamaha RX-V381 an OLED55C8LLA
    ET10000 mit WDC WD30EZRX-00M und WD MyCloud Mirror G2 über Samsung HW-K450 + SWA-8000S an Pioneer PDP-436RXE mit OpenMultiBoot

Unsere Partnerboards

MOSC
Flag Counter