Uhrzeit hat 10 Minuten offset

    This site uses cookies. By continuing to browse this site, you are agreeing to our use of cookies. More details

      Uhrzeit hat 10 Minuten offset

      Hallo,
      ich habe seit einiger Zeit einen 10 Minuten Offset in der Uhrzeit. Ich habe in den Einstellungen schon versucht die Uhrzeit nur via NTP zu aktualisieren. Selbst ein manuelles einstellen via Telnet hat mir nicht geholfen. Mehrfache reboots haben auch nicht geholfen. Der Receiver startet immer auf ARD (ist auch so eingestellt) Wenn ich ntpupdate ausführe bekomme ich folgende Info:

      ntpdate ntp1.ptb.de
      24 Jan 02:49:30 ntpdate[2204]: step time server 192.53.103.108 offset -626.170954 sec

      Hat irgend jemand eine Idee woran es liegen könnte?

      HDF Version: V5.5 Build#179

      Danke
      Gruß
      Xena_two
      Hatte ich schon probiert, auch mit dem Parameter -sb hat es nicht geholfen. Ich habe danach den Receiver gebootet, aber leider kein Erfolg. Konstant 10 Minuten offset.

      Auch wenn ich mit date eine Uhrzeit setze ändert es nicht. Es wird irgendwie überhaupt nicht übernommen.

      root@dm7080:~# date -s 2017.01.24-17:30:00
      Tue Jan 24 17:30:00 CET 2017
      root@dm7080:~# date
      Tue Jan 24 17:40:28 CET 2017

      Bei meiner dm800se passt die Zeit.

      Gruß
      Xena_two
      Ja, ich weiß, der Thread ist alt, aber er ist der einzige Treffer in der Suche und so will ich nicht extra einen neuen deswegen aufmachen.

      Ich hatte heute das gleiche Problem mit meiner XTrend ET9200, wobei die Zeit bei mir auf einmal über eine Stunde vorn war. Es trat während dem Zappen quer durch meine Favoriten und IPTV-Senderlisten auf, wobei mir das wohl nicht gleich auffiel und ich daher nicht genau sagen kann, bei welchem Sender. Meine Konfiguration ist übrigens so eingestellt, dass die Zeit vom Transponder genommen werden soll, aber die hat dann nicht mehr gegriffen.

      Ich wollte das Problem auf der Shell lösen, nur gibt es scheinbar nur einen Befehl quer durchs Unix, der eine so große Zeitabweichung beheben lässt, bei mehr als einer Sekunde oder so ist Schluss (irgendwie schräg, ist aber so). Der Befehl funktioniert aber nicht, weil nptd in der Version auf der Box den -g Parameter nicht kennt. Kann man hier vielleicht nptd im Image aktualisieren?

      Wie oben beschrieben konnte auch ich das Problem beheben, indem ich für ein paar Minuten den Stecker zog.
      Den Befehl gibt es es in der HDF-Toolbox unter Tools und kann mit der Fernbedienung ausgeführt werden.
      Meine Bastelboxen: Mut@nt HD51 | GB Quad 4K | Mut@nt HD60 | OSMIO4K | HIS 4k Combo+

      ... Keinen Support per PN ... bitte stellt eure Fragen ins Forum!...

      ~ Benutzung OpenHDF Image ~ Benutzung der HDF-Toolbox ~ FAQ und Linksammlung ~ Build und Foren Server Spendenaktion ~
      Wenn Du schon auf Shell-Ebene arbeitest, dann kannst Du auch
      den Befehl date verwenden. (date ist eine Funktion der BusyBox)

      date ohne Parameter zeigt Dir die aktuelle Zeit an.
      date 10:20:34 stellt die Zeit auf 10 Uhr 20 Minuten und 34 Sekunden ein. (zum Beispiel)

      date --help fuer mehr Info

      Nebenbei bemerkt, ntpd auf einer STB ist, als wolltest Du mit einem 5 Kg Hammer eine
      Reißzwecke einschlagen.

      Außerdem steht Dir auch noch ntpdate (Bordmittel) zur Verfügung, mit dem
      Du die Zeit eines externen Zeitservers übernehmen kannst.

      Zum Beispiel:
      ntpdate 192.53.103.108

      (192.53.103.108 == ptbtime1.ptb.de 1.Zeitserver der Physikalisch-Technischen Bundesanstalt Braunschweig)
      Alles probiert, date -s ..., ntpdate und ntpd. Alle Befehle suggerieren in deren Output, dass sie das machen, was sie sollten. Beim darauffolgenden Aufruf von date stand wieder die Uhrzeit in der Zukunft da.

      Bei date +'%s' standen sogar die wirklich richtigen Sekunden da, was mir epochconverter.com/ bestätigt hat. date allein war dann trotzdem wieder falsch.

      Wie gesagt, das Hauptproblem bestand darin, dass die Zeitabweichung (AKA Offset) zu groß war. Ich habe keine Ahnung, warum Unix das so einschränkt, weil man gerade da eigentlich viele Freiheiten hat. Aber alle Internetseiten schreiben das so logisch hin, als ob das das vollkommen Normalste sei, eine solche Einschränkung zu haben.

      Scheinbar gibt es nur den -g Parameter bei ntpd. Und den kennt wie gesagt nptd auf der Box nicht.

      Und halt Stromlosmachen für ein paar Minuten :) Ist halt die Hardware-Lösung.
      @Koivo
      Hab' die oberen Posts nicht gesehen/gelesen.

      @verminator
      Sieht so aus als wäre das manuelle Setzen der Systemzeit nicht möglich
      wenn der Hardware Timer der Box strubbelig ist.

      Ansonsten kann man z.B. mit "date 10:20:34" (ohne -s) die Systemzeit auf jede willkürlich gewählte
      Zeit setzen, ohne Offset-Beschränkung. (Getestet auf Quad 4K)

    Unsere Partnerboards

    MOSC
    Flag Counter